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Introduction

Thank you for purchasing a Panasonic product. Before you use the product, please carefully
read through the installation instructions and the manuals, and understand them in detail to use
the product properly.

Types of Manual

● There are different types of manuals for the GM1 series, as listed below. Refer to the
appropriate manual according to your need.
These manuals can be downloaded from our website: https://industrial.panasonic.com/ac/e/
motor/motion-controller/mc/gm1/index.jsp

Manuals for GM1 series

Manual name Manual code Description

GM1 Controller EtherCAT User's
Manual
(Setup Edition)

WUME-
GM1ETCSU

Explains wiring between the GM1 and its
peripheral devices, installation method, and
operation check method.

GM1 Controller EtherCAT User's
Manual
(Operation Edition)

WUME-
GM1ETCOP

Explains how to use GM Programmer and
PANATERM Lite for GM, set up each function,
create projects, and perform other operations.

GM1 Series Reference Manual
(Hardware Edition)

WUME-GM1H Explains the functions and performance of each
GM1 unit.

GM1 Series Reference Manual
(Instruction Edition)

WUME-GM1PGR Explains the specifications of each instruction that
can be used with the GM1 Series.

GM1 Series Reference Manual
(Analog I/O Unit)

WUME-GM1AIO Explains the functions and performance of each
GM1 Analog Expansion Unit.

GM1 Series Reference Manual
(Pulse Output Unit)

WUME-GM1PG Explains the functions and performance of each
GM1 Pulse Output unit.

Copyright / Trademarks

● The copyright of this manual belongs to Panasonic Industry Co., Ltd..
● Unauthorized reproduction of this manual is strictly prohibited.
● Windows is a registered trademark of Microsoft Corporation in the U.S. and other countries.
● Ethernet is a registered trademark of FUJIFILM Business Innovation Corp. and Xerox Corporation.
● EtherCAT is a registered trademark of and patented technology licensed by Beckhoff Automation GmbH,

Germany.
● EtherNet/IP is a registered trademark of ODVA (Open DeviceNet Vendor Association).
● SDHC and SD logos are trademarks of LLC.
● Other company and product names are trademarks or registered trademarks of their respective companies.
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1.1 Safety Precautions

This section explains important rules that must be observed to prevent personal injury and
property damage.
● Injuries and damages that may occur as a result of incorrect use are classified into the

following levels and safety precautions are explained according to the level.

Indicates that there is a risk of death or serious injury

Indicates that there is a risk of minor injury or property damage

Indicates an action that is prohibited

Indicates an action that must be taken

● Take safety measures outside this product to ensure the safety of the entire system even
if this product fails or an error occurs due to external factors.

● Do not use this product in atmospheres that contain flammable gases.
Doing so may result in explosion.

● Do not throw this product into the fire.
Doing so may cause the batteries or other electronic parts to explode.

● To prevent abnormal heat generation or smoke generation, use this product with some
leeway from the guaranteed characteristics and performance values of the product.

● Do not disassemble or modify this product.
Doing so may result in abnormal heat generation or smoke generation.

● Do not touch any terminals while the power is on.
Doing so may result in electrical shock.

● Configure emergency stop and interlock circuits outside this product.

● Connect wires and connectors properly.
Failure to do so may result in abnormal heat generation or smoke generation.

● Do not perform work (such as connection or removal) with the power turned on.
Doing so may result in electrical shock.

● If this product is used in any way that is not specified by Panasonic, its protection function
may be impaired.

● This product has been developed and manufactured for industrial use only.

1.1 Safety Precautions
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1.2 Description of Icons Used in this Document

■ In this manual, the following symbols are used to indicate safety information that
must be observed.

Indicates an action that is prohibited or a matter that requires caution.

Indicates an action that must be taken.

Indicates supplemental information.

Indicates details about the subject in question or information useful to remember.

Indicates operation procedures.

1.2 Description of Icons Used in this Document
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1.3 Software License Agreement

Panasonic Industry Co., Ltd. (“PANASONIC”) grants to you a license to use this Software on
condition that you accept this Agreement. You must read this Software License Agreement (this
“Agreement”) carefully before using this Software. Only in case that you accept this Agreement,
you may start your use of this Software.
Your unsealing the package of this Software, or your downloading, installing or launching this
Software or the like shall be deemed as your acceptance of this Agreement.
The Software includes not only proprietary computer programs owned by or licensed by
PANASONIC but also open source software programs. As for the open source software
programs, refer to the detailed terms and conditions thereof shown in the installation package of
the Software. Should a discrepancy arise between any of the terms of this Agreement and any
open source software program license statement, the open source software program license
statement shall take precedence over this Agreement.
Article 1 Grant of License
PANASONIC hereby grants to you a non-exclusive license to use this Software only in
combination with PANASONIC product(s) specified in the manual of this Software (the
“Product”) in accordance with the terms of this Agreement. You may not use this Software in
connection with products of any third party other than PANASONIC.
Article 2 Restrictions
You may NOT:
1. Modify, reverse engineer, decompile, or disassemble this Software, except where the terms

and conditions of open source software program license statement (including, but not
limited to, GPL and LGPL) apply.
Should a defect of the Software arise owing to your modification, reverse engineering,
decompiling, or disassembling, to the extent permitted under the law,PANASONIC shall not
assume any responsibility for such defect,

2. Use this Software by methods or for purposes other than those specified in the manual of
this Software provided by PANASONIC, nor

3. Distribute, rent, lease or otherwise transfer this Software to any third party; provided,
however, that you may assign the rights to use this Software under this Agreement along with
the Product on the condition that the assignee agrees to be bound by all the terms of this
Agreement. In the case of such assignment, you must deliver any and all the copies of this
Software and all the accompanying materials to the assignee and you may not retain any
copies of this Software including backups.
Article 3 Disclaimer
1. PANASONIC HEREBY DISCLAIMS ALL OTHER WARRANTIES ON THIS SOFTWARE,

EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED
WARRANTIES OF MARCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE, AND
NON-INFRINGEMENT OF THIRD PARTY RIGHTS.

2. UNDER NO CIRCUMSTANCES SHALL PANASONIC BE LIABLE FOR ANY DAMAGES
(INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL OR SPECIAL OR
WHATSOEVER) ARISING OUT OF THE USE OF THIS SOFTWARE, INABILITY TO USE
THIS SOFTWARE, DEFECTS IN THIS SOFTWARE (e.g., BUGS, SECURITY HOLES,
AND MALFUNCTION), OR OTHERWISE IN CONNECTION WITH THIS SOFTWARE.

Article 4 Term
1. This Agreement shall come into effect upon your unsealing the package of this Software, or

your downloading, installing or launching this Software or the like.

1.3 Software License Agreement
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2. PANASONIC may terminate this Agreement immediately, if you breach any of the
provisions of this Agreement.

3. You shall, at your own costs, return, delete or destroy this Software and any of its copies
within four (4) weeks after termination of this Agreement.

Article 5 Export Control
You shall comply with all laws and regulations regarding export control under any competent
jurisdiction, including but not limited to the Japanese Foreign Exchange & Foreign Trade
Control Law, the export control regulations based on resolutions of the United Nations Security
Council, etc. If any license or appropriate approval from a governmental authority is required
under the applicable laws, you may not export this Software without such approval to any
countries either directly or indirectly. Furthermore, you shall neither use nor sell this Software
for military purposes either directly or indirectly.
Article 6 Intellectual Property Rights
Except the open source software program (including, but not limited to, GPL and LGPL), all
intellectual property rights in this Software, including the copyright, belong to PANASONIC
and/or the licensors of PANASONIC.
Article 7 Upgrade of this Software
1. Release of future upgrades or updates of this Software is not guaranteed and left to the

sole discretion of PANASONIC. Furthermore, PANASONIC may charge fees for upgrading
or updating of this Software.

2. If any upgrades or updates are provided to you either for fees or for free, such upgrades or
updates shall be deemed as a part of this Software and shall be governed by this
Agreement, unless PANASONIC designates otherwise at the time of provision of such
upgrades or updates.

Article 8 Limitation on Liability
AGGREGATE LIABILITIES OF PANASONIC IN CONNECTION WITH THIS AGREEMENT OR
THIS SOFTWARE SHALL IN NO EVENT EXCEED TEN THOUSAND (10,000) YEN.
Article 9 Governing Law and Jurisdiction
1. This Agreement shall be governed by the laws of Japan.
2. Should any dispute arise from or in connection with this Agreement, Osaka District Court,

Japan shall exclusively have the jurisdiction over such dispute.
This Software consists of the following types of software.
1. Software developed independently by PANASONIC
2. Software owned by and licensed by the third party
3. Software licensed under GNU General Public License Version 2.0 (GPL V2.0)
4. Software licensed under GNU Lesser General Public License Version 2.0 (LGPL V2.0) or

Version 2.1 (LGPL V2.1)
5. Open source software licensed on conditions other than those of GPL V2.0, LGPL V2.0, or

LGPL V2.1
Software in categories 3. - 5. above is distributed with the expectation of effectiveness as a
single piece of software, but there is no guarantee provided, including implied guarantees
regarding viability as a product and/or suitability for specific purposes. For details, Please refer
to the detailed terms and conditions thereof shown in the installation package of the Software.
For at least three years following the release of the Product, PID will provide, at customer's
expense, complete machine-readable source code for software licensed under GPL V2.0,
LGPL V2.0, LGPL V2.1, or a license based on other conditions that meet source code
disclosure requirements, along with information on the respective copyright holders, to
customers who contact us at the following e-mail address.
【Contact e-mail address: oss-cd-request@gg.jp.panasonic.com】

1.3 Software License Agreement
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2 Basic System Configuration

2.1  Outline of the GM1 System.................................................................2-2
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2.1 Outline of the GM1 System

■ Network control
A MINAS series servomotor network system can be easily configured by adopting EtherCAT
communication.

■ System configuration including virtual axes
A motion system that combines real and virtual axes can be configured.

■ Two LAN ports
There are two Ethernet connection ports.
Each port can have a unique IP address. They can be used for different purposes, such as for
an in-device network or for a host system network.

■ Equipped with the high-speed counter input and PWM output
The GM1 Controller is equipped with a 2-ch high-speed counter input for 16 MHz (multiplied by
4) and a 4-ch PWM output that can output a maximum of 100 kHz. These functions can be
used without adding expansion units.

2.1 Outline of the GM1 System
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2.2 Unit Types

■ Controller

Type Function Product number

GM1 EtherCAT compatible
controller (sink type)

EtherCAT motion controller
Transistor NPN type

AGM1CSEC16T

GM1 EtherCAT compatible
controller (source type)

EtherCAT motion controller
Transistor PNP type

AGM1CSEC16P

■ Expansion unit

Type Function Product number

64 digital input points 24 V DC, 64 input points AGM1X64D2

64 digital output points (sink type) 64 output points
Transistor NPN type AGM1Y64T

64 digital output points (source
type)

64 output points
Transistor PNP type AGM1Y64P

64 digital I/O points (sink type)
24 V DC, 32 input points
32 output points
Transistor NPN type

AGM1XY64D2T

64 digital I/O points (source type)
24 V DC, 32 input points
32 output points
Transistor PNP type

AGM1XY64D2P

8 analog input points 8 input points AGM1AD8

4 analog output points 4 output points AGM1DA4

Pulse output (transistor output type)
4 axes, pulse train, 500 kpps
Open collector output

AGM1PG04T

Pulse output (line driver output
type)

4 axes, pulse train, 4 Mpps
Line driver output

AGM1PG04L

2.2 Unit Types
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2.3 Restrictions on the Number of Expansion Units

Up to 15 expansion units can be mounted on the right side of the GM1 Controller.

(1) Controller (2) Expansion unit (3) End unit

● Be sure to connect an end unit to the end of the system.

2.3 Restrictions on the Number of Expansion Units
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3 Restrictions on the GM1
Controller and Servo
Amplifiers

3.1  Restrictions on the Combination of the GM1 Controller and Servo
Amplifiers ..............................................................................................3-2

3.2  Restrictions on Servo Amplifier Parameters .......................................3-3
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3.1 Restrictions on the Combination of the GM1 Controller and Servo
Amplifiers

As for the combination of the GM1 Controller and each MINAS series, confirm the following
restrictions.

Combination of the GM1 Controller and servo amplifiers

Connectable servo amplifier
Description

A5B A6B

● ● A5B and A6B can be connected to the same network.

● When using servo amplifiers in combination with the GM1 Controller, use the ones with the
latest software version.

■ Setting ranges of movement amount and speed
The input range of the movement amount or speed specified in the GM1 Controller may differ
from the upper and lower setting limits of the servo amplifier.

● The respective control cycles supported by the GM1 Controller and servo amplifiers A5B and
A6B are shown below.
• GM1 Controller: 500 μs to 4 ms (control cycle)
• Servo amplifier A5B: 500 μs to 4 ms (control cycle)
• Servo amplifier A6B: 500 μs to 4 ms (control cycle)

3.1 Restrictions on the Combination of the GM1 Controller and Servo
Amplifiers
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3.2 Restrictions on Servo Amplifier Parameters

Some parameters of servo amplifiers affect the operation of the GM1 Controller. Use the
following parameter.

No. Name Settings
Factory
default
setting

Pr5.04
Over-travel
inhibit input
setup

Use set value 1.
(Recommended) 1(Note 1)

 

(Note 1) We recommend that the set value not be changed due to the characteristics of the GM1 and MINAS.
 

3.2 Restrictions on Servo Amplifier Parameters
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4 Basic Operations of the GM1
Controller
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4.2  Operation Mode Switching..................................................................4-3
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4.1 Power ON

When turning ON the power to the system incorporating the GM1 Controller, follow the power
ON sequence described in the procedure below.

● Consider the performance and statuses of any external devices connected to the system,
and take sufficient care so that turning ON the power will not initiate unexpected
movements.

1. Turn ON the power to the I/O devices connected to the GM1 Controller.

2. Turn ON the power to the servo amplifier.

3. Turn ON the power to the GM1 Controller.

4.1 Power ON
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4.2 Operation Mode Switching

■ Switching to the RUN mode
There are the following two methods.
● Press the operation button (▶) on the GM Programmer while the STOP LED is lit.
● Set the RUN/STOP switch on the GM1 Controller to RUN.

● The switch cannot be set to the RUN mode if an error that does not allow to continue operation
has occurred or if an exceptional situation has occurred.

■ Switching to the STOP mode
There are the following two methods.
● Press the stop button (■) on the GM Programmer while the RUN LED is lit.
● Set the RUN/STOP switch on the GM1 Controller to STOP.

4.2 Operation Mode Switching
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5 Installation and System
Setup

5.1  System Configuration Diagram...........................................................5-2
5.2  Work Flowchart ...................................................................................5-4
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5.1 System Configuration Diagram

The figure below shows the configuration of the GM1 series motion controller (controller and
expansion units), servo amplifiers, and PC. GM Programmer and PANATERM Lite for GM
communicate with the GM1 Controller via Gateway.

No. Name

(1) GM1 Controller

(2) Expansion unit

(3) End unit

(4) Servo amplifier

(5) PC (on which GM Programmer and PANATERM Lite for GM are installed)

(6) Gateway, CodeMeter

(7) GM Programmer

(8) PANATERM Lite for GM

(9) Ethernet cable(Note 1)

(10) USB cable(Note 1)

 

(Note 1) Use either Ethernet cables or USB cables.
 

5.1 System Configuration Diagram
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● To operate the system, you must install GM Programmer and PANATERM Lite for GM on the
PC.

● When GM Programmer is installed, MINAS setup support software "PANATERM Lite for GM",
Gateway (the application that connects GM Programmer and the GM1 Controller), and
CodeMeter are installed at the same time.

5.1 System Configuration Diagram
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5.2 Work Flowchart

The following table explains the workflow from installation of the GM1 Controller through to its
operation.

Step Description Reference

1 Install GM Programmer and PANATERM Lite for GM. "P.6-3"

2 Make preparations for the servo amplifiers. "P.8-1"

2-1 Connect the servo amplifiers and the PC. "P.8-2"

2-2 Install the USB driver on the PC. "P.8-2"

2-3 Configure initial settings for the servo amplifiers. "P.8-2"

2-4 Disconnect the servo amplifiers from the PC. "P.8-4"

3 Connect the GM1 Controller and each servo amplifier with cables. "P.9-1"

4 Connect the GM1 Controller and GM Programmer. "P.10-1"

4-1 Connect the GM1 Controller and the PC with a cable. "P.10-2"

4-2 Create a new project. "P.10-3"

4-3 Configure communication settings. "P.10-6"

4-4 Add and set up device objects for servo amplifiers. "P.10-10"

4-5 Configure basic settings for EtherCAT axes. "P.10-15"

4-6 Connect the GM1 Controller to the PC and each servo amplifier
and perform an operation check.

"P.10-22"

4-7 Log in to the GM1 Controller. "P.10-25"

4-8 Log out from the GM1 Controller. "P.10-26"

5 Connect the GM1 Controller and PANATERM Lite for GM. "P.11-1"

5-1 Set up the servo amplifier connected to the GM1 Controller. "P.11-2"

5-2 Write parameters to the servo amplifier. "P.11-8"

5-3 Write objects to the servo amplifier. "P.11-9"

6 Prepare for operation. "P.12-1"

6-1 Check if a safety circuit is designed properly. "P.12-3"

6-2 Check wiring for each device. "P.12-2"

6-3 Perform an operation check. "P.12-7"

7 Using GM Programmer, configure settings for GM1 parameters, motion
control, unit control, and communication function.

GM1 Controller
EtherCAT User's
Manual (Operation
Edition)7-1 Configure settings for the GM1 Controller.

7-2 Configure settings for motion control.

7-3 Configure settings for unit control.

7-4 Configure settings for the communication function.

8 Create programs with GM Programmer.

8-1 Create objects (POU objects) for a program.

8-2 Select a programming language (LD, ST, SFC, FBD, IL, or CFC)
and enter a program.

5.2 Work Flowchart
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Step Description Reference

8-3 Set variables.

9 Set up the GM1 Controller in GM Programmer.

9-1 Configure time settings.

9-2 Log in to the GM1 Controller.

9-3 Log out from the GM1 Controller.

9-4 Upload the source.

10 Configure security settings with GM Programmer.

10-1 Configure user management settings.

10-2 Configure encryption and signature settings.

10-3 Configure write-protection settings.

5.2 Work Flowchart
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6.1 System Requirements

6.1.1 Usage Environment of the GM Programmer

Programming software

Product name Applicable language

GM Programmer Japanese / English / Chinese
 

(Note 1) When GM Programmer is installed, MINAS setup support software"PANATERM Lite for GM"is
installed at the same time.

 

Software operating environment

Item Description

OS
Microsoft(R) Windows(R) 10：32bit/64bit
Microsoft(R) Windows(R) 11：64bit

PC

PC with the following installed:
● Microsoft.NET Framework 4.6.1 or higher
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
● Microsoft Visual C++ 2013 Redistributable Package (x86)
● Microsoft Visual C++ 2013 Redistributable Package (x64)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x86)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x64)

HDD At least 4 GB of free space

Memory At least 8 GB

Communication port
LAN port (for Ethernet connection)
USB 2.0 port (for USB connection)

6.1 System Requirements
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6.2 Installation and Uninstallation

6.2.1 Installing GM Programmer

Before installing the GM Programmer on a PC, log on to the PC as an account with
Administrator privileges.
If other applications are running, be sure to close all the applications before installing GM
Programmer.

1. Double-click "setup.exe".
The following window will be displayed. Click [OK].

2. The following window will be displayed. Click [Install].
The display content differs according to the PC environment that you use. (This window
may not be displayed at all, depending on the situation.)

6.2 Installation and Uninstallation
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3. The following window will be displayed. Click [Next].

4. The following window will be displayed. Select [I accept the terms in the license agreement]
and click [Next].

5. The following window will be displayed. If you change the installation destination folder,
click [Change] and specify a desired installation destination. If you do not change the
installation destination folder, click [Next].

6.2 Installation and Uninstallation
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6. The window below will be displayed. Click [Install] to start the installation.

7. The following window will be displayed while the installation is in progress.

6.2 Installation and Uninstallation
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Following this installation, the three packages below will be installed. (The segments
indicated by * differ according to the version of the software.)
● CODESYS SoftMotion*.*.*.*_P
● GMPLibrary (*.*.*.*)
● PANATERM-Lite for GM V*.*
These packages take a long time to install. Take care not to click [Cancel] while the
installation is in progress.

8. When the installation of all the packages is completed, the following window will be
displayed. Click [Finish].

6.2 Installation and Uninstallation
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This completes the installation procedure.

● When the GM Programmer is installed, PANATERM Lite for GM, Gateway (CODESYS
Gateway), and CodeMeter applications are installed at the same time.

6.2.2 Uninstalling GM Programmer

1. From the Start menu, select Windows System>Control Panel, and then click "Uninstall a
program".
A list of installed programs will be displayed.

2. Double-click "Panasonic GM Programmer".
The following window will be displayed. [Yes]

3. Click the [Yes] button.
The GM Programmer will be uninstalled.

● When the GM Programmer is uninstalled, PANATERM Lite for GM and Gateway are also
uninstalled at the same time.

● CodeMeter will not be uninstalled at this time. Uninstall it separately.

6.2 Installation and Uninstallation
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6.3 Basic Operations

This section explains how to start and quit GM Programmer.

6.3.1 How to start

1. Click the [Start] button and select Panasonic Corpration>GM Programmer.
The "User Account Control" dialog box will be displayed. Click [Yes].

GM Programmer will be started.

6.3 Basic Operations
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6.3.2 How to quit

● Before closing GM Programmer, be sure to save any project files that you are editing and
must save.

1. From the menu bar, select File>Exit.
If changes have not been saved, the following window will be displayed.
If exiting without saving, select [No].
If changes need to be saved, select [Yes] to perform the save process.

2. Click the [Yes] button.
GM Programmer will be closed.

● You can also close GM Programmer by clicking the [×] button on the title bar.

6.3 Basic Operations
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6.4 Component Names

This section presents the name and display content of each component of GM Programmer.

No. Name Description

(1) Title bar The title bar displays the project file name, [minimize] button, [maximize] button, and
[close] button.

(2) Menu bar The menu bar displays the menu commands for each purpose in list format.

(3) Toolbar The toolbar displays each command as an icon.

(4) Navigator pane The navigator pane displays the objects (such as devices, applications, and programs)
added to the project in a tree structure.

(5) Main pane
The main pane displays a program, function settings, messages, and other data.
The window can be switched by selecting a desired tab.

(6) Status field The status bar displays the build status, logged-in users, and other information.

6.4 Component Names
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6.5 Other Functions

6.5.1 Display Language Setting Function

This function allows the user to change the display language setting for GM Programmer.
The default setting is the same language as the one used in the operating system. If you want
to use a different language from the one used in the operating system, change the display
language setting. After you change the language setting, you must restart GM Programmer.

1. From the menu bar, select Tools>Options.
The "Options" dialog box will be displayed.

2. Select "International Settings" from the Categories pane.
The "International Settings" pane will be displayed.

3. Select User Interface Language>Specific language option and specify a desired
language in the field.

4. Click [OK].
The "Options" dialog box will be closed.
At this stage, the language has not been changed yet.

5. Close GM Programmer and then start GM Programmer again.
After GM Programmer is started, the selected language takes effect.

6.5 Other Functions
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● The display language setting of GM Programmer is linked with that of PANATERM Lite for GM.
Therefore, if the display language setting of PANATERM Lite for GM is changed, the display
language setting of GM Programmer will also be changed automatically.

6.5.2 Online Help Function

This function allows the user to open the manual and check information such as operating
methods.

1. Press the [F1] key.
Online help will be started and the page corresponding to the displayed window will be
displayed.

6.5 Other Functions

6-12 WUME-GM1ETCSU-04



● You can also start online help by selecting Help>Manual from the menu bar.

6.5.3 Version Display Function

This function allows the user to check the version, license, and other information for GM
Programmer.

1. From the menu bar, select Help>Version Info.
The GM Programmer version is displayed in parentheses on the title bar.

2. Click a desired button at the bottom of the window.

Button Description

Version Info Displays information about the plug-ins that have been applied and the operating
system of the PC that is used.

License Info Displays license information for the software used by GM Programmer.

Clicking the[Version Info]button displays the"Version Info"dialog box.

6.5 Other Functions
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Clicking the[License Info]button displays the"License Information"dialog box.

6.5 Other Functions
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7.1 System Requirements

7.1.1 Operating Environment of PANATERM Lite for GM

Programming software

Product name Applicable language

PANATERM Lite for GM Japanese / English / Chinese
 

(Note 1) When GM Programmer is installed, MINAS setup support software"PANATERM Lite for GM"is
installed at the same time.

 

Software operating environment

Item Description

OS Microsoft(R) Windows(R) 10: 32bit / 64bit

PC

PC with the following software installed:
● Microsoft.NET Framework 4.6.1 or later
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
● Microsoft Visual C++ 2013 Redistributable Package (x86)
● Microsoft Visual C++ 2013 Redistributable Package (x64)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x86)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x64)

HDD At least 4 GB of free space

Memory At least 8 GB

Communication port
LAN port (for Ethernet connection)
USB 2.0 port (for USB connection)

7.1 System Requirements
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7.2 Basic Operations

This section explains how to start and exit PANATERM Lite for GM.

7.2.1 How to Start

1. Click the [Start] button in the Windows task bar and select Panasonic
Corporation>PANATERM Lite for GM.

2. The "Connect" dialog box will be displayed.
Select a communication setting option and click [OK].

3. The "Series Setting" dialog box will be displayed.

7.2 Basic Operations
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7.2 Basic Operations
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When the "Selection of Aircraft Types" dialog box is displayed, select a model and click the
"OK" button.

4. PANATERM Lite for GM will be started.

7.2 Basic Operations
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7.2.2 How to Exit

● Note that all information will be lost if you close the program without saving settings,
collected data, or other information.

1. From the menu bar, select File>Exit.
PANATERM Lite for GM will be closed.

● You can also close PANATERM Lite for GM by clicking the [×] button on the title bar.

7.2 Basic Operations
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7.3 Component Names

This section explains the components and displays of PANATERM Lite for GM.

No. Name Description

(1) Title bar The title bar displays the project file name, [minimize] button, [maximize] button, and
[close] button.

(2) Menu bar The menu bar displays the menu commands for each purpose in list format.

(3) Toolbar The toolbar displays each command as an icon.

(4) Navigator pane This pane displays a list of axes.

(5) Main pane
This pane displays the Parameter window, Monitor window, Alarm window, and other
windows.
The window can be switched by selecting a desired tab.

(6) Status field This field displays the status of connection to the GM1 controller.

7.3 Component Names
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7.4 Parameter Window

The Parameter window allows the user to check and rewrite the values of servo amplifier
parameters, save them to parameter files, and perform other parameter-related operations.

7.4.1 Configuration of Parameters Window

No. Name Function

(1) Toolbar

The toolbar consists of basic operation commands related to parameters,
such as save and read.

Icon Name Function

Read

Reads parameters from file ".prm5".
When this button is enabled, you can
specify a parameter file also by drag-and-
drop operation.

Save Writes parameters to file ".prm5".

Rcv Receives parameters from the servo
amplifier.

7.4 Parameter Window

7-8 WUME-GM1ETCSU-04



No. Name Function

Icon Name Function

Trans Transmits parameters to the servo
amplifier.

Copy
Copies the parameters of a servo
amplifier to servo amplifiers for other
axes.

EEP Writes parameters to EEPROM of the
servo amplifier.

Bin / Hex Inputs the selected settings in binary or
hexadecimal format.

Print Prints parameters.

Pin assignment
setting Sets I/O pin assignment.

(2) Theme selection pane

After a theme is selected, if a parameter category is selected from a sub-
theme, related parameters will be displayed in the parameter setting area.

For details on each parameter, refer to the instruction manual and other
technical references for the servo amplifier.

(3) Parameter setting area

Allows the user to set or edit parameters.

Name Function

Class Displays parameter categories

No. Displays parameter numbers

Parameter Name Displays parameter names

Setup Range Displays the maximum and minimum allowable
values of parameter settings

Value

Displays parameter values. Values can be changed.
For parameters provided with a ▼ button beside the
set value, a desired value can be selected from the
combo box. After selecting a value from the combo
box, press the <Enter> key. For parameters without
a ▼ button beside the set value, either directly enter
a value using <numerical> keys or click "▲""▼" to
edit the value by increasing or decreasing it. To set a

7.4 Parameter Window
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No. Name Function

Name Function
value, press the <Enter> key. To return a value to its
original value, press the <Esc> key.

Unit Displays the unit of parameter settings.

(4) Text display area Displays a description related to the selected parameter.

(5) Parameter attribute
description area

Displays a description of parameter attributes. The background color of each
parameter in the parameter setting area represents an attribute.

(6) "Display-set value
description" check box

Selecting the check box displays combo boxes and decimal points in the
"Value" column of the parameter setting area. To display parameter set
values in an easy-to-understand manner, select the check box.

7.4.2 Setting Parameters

1. From the menu bar on the main pane, select View>Parameter. Alternatively, on the toolbar,
click the "Open the Parameter view" icon.

The "Selection of parameter to be read" dialog box will be displayed.

7.4 Parameter Window
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Read-out from the driver
Communicates with the connected servo amplifier and reads the parameter settings from
the servo amplifier. If this mode is selected, parameter values will be reflected in the servo
amplifier as soon as they are changed.
Read from file
Reads the parameter file (".prm5") that was edited previously. If communication is
performed with the servo amplifier, parameter values will be reflected in the servo amplifier
as soon as they are changed.
Read default
Reads the factory default settings of the servo amplifier that were saved during
installation. If communication is performed with the servo amplifier, parameter values will
be reflected in the servo amplifier as soon as they are changed.

2. Select one of the three options above and click the [OK] button.
The Parameter window will be displayed.

7.4 Parameter Window
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3. After changing the parameter settings, click the [EEP] button to write the parameter settings
to the EEPROM of the servo amplifier.

4. Click the [×] button on the Parameter window to close the Parameter window.

7.4 Parameter Window
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7.5 Object Window

Troubleshooting can be performed more easily by displaying and editing the list of objects on
the amplifier side without using a host device.

● Some objects affect the behaviors of servo amplifiers or motors. Therefore, before changing
the objects, carefully read the instruction manual and other technical references for the servo
amplifier and pay careful attention when changing them.

7.5.1 Configuration of Object Window

No. Name Function

(1) Toolbar

The toolbar consists of basic operation commands related to objects, such as save
and read.

Icon Name Function

Read
Reads objects from the file (.obj5).
When this button is enabled, you can specify a file by
drag-and-drop operation.

Save Writes objects to the file (.obj5).

Rcv Receives objects from the servo amplifier.

7.5 Object Window
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No. Name Function

Trans Transmits objects to the servo amplifier.
If you turn OFF the power supply to the servo amplifier
without writing to EEPROM, the object will be reverted
back to the value before the change was made.

Copy Copies the objects of a servo amplifier to servo amplifiers
for other axes.

EEP

Writes objects to EEPROM of the servo amplifier.
Do not turn OFF the power supply to the servo amplifier
and the PC while data is being written to EEPROM.
If the power supply is cut off while data is being written,
the data content is not warranted.

Print Prints objects.

Display
mode

Changes the numerical display of the object being
displayed.
Hex: Displayed in hexadecimal number and “h” is placed
at the end of the number.
Dec: Displayed in decimal number and a sign is set.
Bin: Displayed in binary number and “b” is placed at the
end of the number.
The values in the Min-Max column are displayed in
hexadecimal number.

(2) Condition
monitor

PDS Condition
Displays the PDS condition on the servo amplifier side.
It varies depending on the object value of 6041h-00h.

ESM Condition
Displays the condition that indicates whether the object can be rewritten on
the servo amplifier side.
Rewriting is possible when “Operational” is displayed.

Full
display

(3) Object tree

When a node is selected from the object tree, related objects are displayed in the
object setting field.
Operate Close TreeView or Open TreeView to hide or display the object tree.
Select “All object” to display all objects.
When a parent node is selected, all child node objects under the selected node are
displayed.
When a child node is selected, objects of the selected node are displayed.
For details of each object, refer to the instruction manual and other technical
references for the servo amplifier.

7.5 Object Window
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No. Name Function

(4) Object setting
field

Allows the user to edit and set an object.

Name Function

"Main
Index" Displays the Main Index of an object.

Sub Index Displays the Sub Index of an object.

Object
Name Displays the name of an object.

Data Type

Displays the data type of an object.
I8: Integer 8 type
I16: Integer 16 type
I32: Integer 32 type
U8: Unsigned 8 type
U16: Unsigned 16 type
U32: Unsigned 32 type
Bool: Boolean type
OS: Octet String type
VS: Visible String type

Attributes
Displays the attributes of an object.
RO: Read-only attribute, exclusively for reading.
RW: Read/write attribute, possible to read or write.

Min Displays the setting range of an object.
The setting range is not displayed for an object whose Data Type is
“OS” or “VS”.Max

Value

Displays the value of an object. The value can be changed if the object
attribute is “RW” and the set value is a numerical value.
Note that there are input restrictions for each Display mode setting. The
following values can be input.
Hex: 0 to 9, A to F (After editing, “"h"” is automatically placed at the end
of the number.)
Dec: 0 to 9 and minus sign “-”
Bin: 0 and 1 (“"b"” is automatically placed at the end of the number.)
After changing the value, press the <ENTER> key or click the [Trans]
button.
To return a value to its original value press the <ESC> key.

Unit Displays the unit of an object set value.

7.5 Object Window
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7.5.2 Setting Objects

1. From the menu bar on the main pane, select View>Object. Alternatively, on the toolbar,
click the "Open the Object view" icon.

The "Selection of objects to be read" dialog box will be displayed.

Read-out from the amplifier.
Communicates with the connected servo amplifier and reads objects set in the servo
amplifier.
If this mode is selected, object values will be reflected in the servo amplifier as soon as
they are changed.

7.5 Object Window
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Read from file
Reads the parameter file ("obj5") that was edited previously. If communication is
performed with the servo amplifier, object values will be reflected in the servo amplifier as
soon as they are changed.
Read default
Reads the standard default settings of the servo amplifier that were saved during
installation.
If communication is performed with the servo amplifier, object values will be reflected in
the servo amplifier as soon as they are changed.

2. Select one of the three options above for reading the object settings and click the [OK]
button.
The Object window will be displayed.

3. After changing the object settings, click the [EEP] button to write the object settings to the
EEPROM of the servo amplifier.

4. Click the [×] button on the Object window to close the Object window.

7.5 Object Window
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7.6 Monitor Window

The Monitor window displays the operating states of servo amplifiers and motors, I/O signals,
internal statuses, and other information and also allows the user to check them.

7.6.1 Configuration of Monitor Window

NO. Name Description

(1) Toolbar

The toolbar consists of basic operation commands related to parameters.

Icon Name Function

Print Prints the contents of the Monitor
window.

(2) Amplifier model name and
serial number Displays the model name and serial number of the servo amplifier.

(3) Output signal status
monitor

Displays the status of each output signal. The tab can be switched between
"Physical Output" and "Logical Output".
Physical Output – Displays the status of output signals from the servo
amplifier.
Red: Indicates that output transistor is ON
Pink: Indicates that output transistor is OFF

7.6 Monitor Window
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NO. Name Description
Logical Output – Displays the status of signals within the servo amplifier.
Red: Indicates that signal status is active
Pink: Indicates that signal status is inactive

(4) Input signal status monitor

Displays the status of input signals. The tab can be switched between
"Physical Input" and "Logical Input".
Physical Input – Displays the status of input signals to the servo amplifier.
Red: Indicates that COM- is connected
Pink: Indicates that signal status is open
Logical Input – Displays the status of signals within the servo amplifier.
Red: Indicates that signal status is active
Pink: Indicates that signal status is inactive

(5) Internal status monitor

Displays the internal status of the servo amplifier.

Name Function

Commanded
position deviation Displays the position deviation of a command unit.

Actual speed Displays the monitor speed

Torque command Displays the torque command.

Load factor Displays the ratio relative to the rated load. Adjust
the operation pattern so that 100% is not exceeded.

Power supply
voltage value

Displays the voltage (voltage between the P and N
terminals) of power supply to the servo amplifier.

(6) Pulse sum monitor Displays the sum of command and encoder pulses received by the servo
amplifier.

(7) Encoder information
monitor

Displays encoder information.

Single-turn data Displays an absolute position when the motor makes
no more than a single turn.

Multi-turn data Displays how many turns the motor made after
"Clear" operation.

Clicking "Clear Multi-turn" resets the multi-turn data stored in the encoder to
"0" and clears all encoder errors.
Note 1: Before using "Clear Multi-turn", check the precautions on use. To
clear encoder errors, you may need to restart the servo amplifier.
Note 2: If the connected device is A5B, single-turn data and multi-turn data
will be displayed as "-".

 

(Note 1) Because Ethernet communication is used to transfer data between the servo amplifier and PC, there
is a difference or delay between the value displayed on the screen and the actual value of the servo
amplifier.

(Note 2) When the polarity is "+", symbol "+" is not displayed.
(Note 3) The monitor function is not a measuring instrument. Use the values displayed in the Monitor window

as a guide.
(Note 4) If the servo amplifier outputs "Error 40.0　Error protection from absolute system failure" or "Error

42.0　Error protection from absolute overspeed", execute "Clear Multi-turn". Unless the absolute
encoder is reset, the alarm cannot be cleared.

 

7.6 Monitor Window
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7.6.2 Checking the Monitor Window

1. From the menu bar on the main pane, select View>Monitor. Alternatively, on the toolbar,
click the "Open the Monitor view" icon.

The Monitor window will be displayed.

7.6 Monitor Window

7-20 WUME-GM1ETCSU-04



2. Check each item.
Check the input signal state, output signal state, and the internal status of the servo
amplifier.

3. Click the [×] button on the Monitor window.
The Monitor window will be closed.

7.6 Monitor Window
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7.7 Alarm Window

If the front panel of the servo amplifier is blinking, such as when the motor is not working, you
can check the alarm status.Please note that the alarm cannot be cleared.

7.7.1 Configuration of Alarm Window

Display of the current errors and warnings (only during communication with servo
amplifier)

7.7 Alarm Window
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Display of error histories

No. Name Description

(1) Toolbar

Icon Name Function

Clear

Allows the user to clear the current
alarm history. If you click this button
after eliminating the cause of the
alarm, the current alarm will be
cleared and normal operation will be
performed. However, you cannot
clear any alarms that cannot be
cleared by alarm clear input signals
of servo amplifiers. In such a case,
turn off the servo amplifier, eliminate
the cause of the alarm, and then
turn the power on again.

Clear Allows the user to clear error
histories.

Print Prints error-related information.

(2) Current error display area

Displays the alarm numbers and names of all errors that are currently
occurring.
The alarm displayed on the top of the list is the alarm displayed on the front
panel of the servo amplifier.

7.7 Alarm Window
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No. Name Description

(3) Error cause / treatment
display area Displays the cause and treatment of the selected error.

(4) Motor internal status
display area Displays the motor internal status in the event of an alarm.

(5) Current warning display
area

Displays the warning numbers and names of all warnings that are currently
occurring.

(6) Warning cause / treatment
display area Displays the cause and treatment of the selected warning.

(7) Error history display area Displays the order of error histories, alarm numbers, and error names.

(8) Error cause / treatment
display area

Displays the cause and treatment of the selected error.

(9) Motor internal status
display area

Displays the motor internal status in the event of an alarm.

 

(Note 1) Some alarms cause tripping as errors but are not recorded in error histories. For alarms that are not
recorded in error histories, refer to the instruction manual of the servo amplifier.

(Note 2) Up to 14 error histories are stored. When more than 14 errors occur, error histories are erased in
chronological order (the oldest error history is erased first).

(Note 3) Up to three histories of motor internal status in the event of an alarm are stored. If an alarm occurs
immediately after the power is turned on, motor internal status may not be captured normally.

 

7.7.2 Checking Alarms

1. From the menu bar on the main pane, select View>Alarm. Alternatively, on the toolbar,
click the "Open the Alarm view" icon.

7.7 Alarm Window
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The Alarm window will be displayed.

2. Check for any errors that are currently occurring.
Click the "Now Error / Warning" tab and check for any errors that are currently occurring.

3. Check for any errors that occurred in the past.
Click the "Error History" tab and check for any errors that occurred in the past.

4. Click the [×] button on the Alarm window.
The Alarm window will be closed.

7.7 Alarm Window
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7.8 Other Functions

7.8.1 Language Setting Function

This function allows the user to set the display language of PANATERM Lite for GM.
The default setting is the same language as the one set in GM Programmer.

1. Select a language from the menu bar tool.
The language set in PANATERM Lite for GM will be switched.

● The display language setting of PANATERM Lite for GM is linked with that of the GM
Programmer.

7.8.2 Help Function

While performing operation in PANATERM Lite for GM, you can start the Help function to check
information such as operating methods.

1. From the menu bar, select Help>PANATERM Lite for GM Help.
"PANATERM Lite for GM Operation Guide" will be started.

7.8.3 Version Display Function

This function allows the user to check the version, license, and other information for
PANATERM Lite for GM.

1. From the menu bar, select Help>About.

7.8 Other Functions
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2. Click a desired button at the bottom of the window.

Button Description

Version Info Displays information about the plug-ins that have been applied and the operating
system of the PC that is used.

License Info Displays license information for the software used by PANATERM Lite for GM.

7.8 Other Functions
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8.1 Initial Setup for Servo Amplifiers

8.1.1 Connecting the Servo Amplifier and PC

Use a USB cable to connect the servo amplifier and a PC on which PANTERM Lite for GM has
been installed.

8.1.2 Installing the USB Driver

When the GM Programmer is installed, the USB driver is also installed at the same time.

8.1.3 Initial Setup for Servo Amplifiers

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

8.1 Initial Setup for Servo Amplifiers
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2. Select "AMP default setting" and click [OK].
The "Model confirmation" dialog box will be displayed.

3. Check the software version of the servo amplifier for which settings are to be changed and
then click [OK].
The "Parameter change" dialog box will be displayed.

8.1 Initial Setup for Servo Amplifiers
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If Pr7.41 is set to 0, the setting of the rotary switch on the front panel of the servo amplifier
and the setting of Pr7.40 will be set as Station alias.

Station alias

High-order 8 bits Low-order 8 bits

3740H setting Rotary switch setting

If Pr7.41 is set to 1, the value of the SII area (0004h) will be set as Station alias.
The value of the SII area (0004h) can be set using the EtherCAT slave device object of GM
Programmer.

4. Click the [OK] button.
The "Setting Complete" dialog box will be displayed.

5. Click the [OK] button.
The main pane will be displayed. Start the servo amplifier.

8.1.4 Disconnecting the Servo Amplifier from the PC

Disconnect the USB cable connecting the PC and the servo amplifier.

8.1 Initial Setup for Servo Amplifiers
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9.1 Setting an Address for Each Servo Amplifier

The following are the address setting methods prescribed by EtherCAT.
● Reading the Value of Rotary Switch
● Reading the Value of SII Area

9.1.1 Reading the Value of Rotary Switch

Addresses are set using the value of the rotary switch on each servo amplifier.
This setting method is explained using MINAS-A5B as an example.
By setting the Pr7.41 parameter to 0, the value of the rotary switch on the front panel can be
used as an address.
In this case, the value of the rotary switch and the value of Pr7.40 are combined and used as
an address.

Station alias

High-order 8 bits Low-order 8 bits

3740H setting Rotary switch setting

9.1.2 Reading the Value of SII Area

Addresses are set using the value of the SII area (0004h) in each servo amplifier.
This setting method is explained using MINAS-A5B as an example.
By setting the Pr7.41 parameter to 1, the value of the SII area (0004h) can be used as an
address.
The value of the SII area (0004h) can be set using the EtherCAT slave device object of GM
Programmer.
The following figure illustrates the correlation between the settings in GM Programmer and the
wiring of each servo amplifier when addresses are set using the value of the SII area.

9.1 Setting an Address for Each Servo Amplifier
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9.2 Connecting the GM1 Controller and Each Servo Amplifier with
Cables

Connect the EtherCAT port on the GM1Controller and each servo amplifier with cables.

9.2 Connecting the GM1 Controller and Each Servo Amplifier with Cables
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10.1 Connecting the GM1 Controller and PC

10.1.1 Selecting a Connection Port for GM Programmer

Select either LAN port connection or USB port connection.

10.1.2 Connecting the GM1 Controller and PC with a Cable

Use an Ethernet cable or USB cable to connect the GM1 Controller and a PC on which GM
Programmer is installed.

10.1 Connecting the GM1 Controller and PC
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10.2 Creating a New Project

When creating a program using GM Programmer for the first time, create a new project. For the
new project, set a device and a programming language to be used.
This section describes how to create a new project.
Given below is an example that explains the procedure to create a project for the GM1
Controller (product number: AGM1CSEC16T/P) in Structured Text (ST) format.

1. Start GM Programmer.
For details on how to start GM Programmer, refer to "6.3.1 How to start".
When GM Programmer is started, the Start Page will be displayed.

2. Select "New Project" under "Basic Operations".
The "New Project" dialog box will be displayed.

10.2 Creating a New Project
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3. Select Projects>Standard project, and specify a project file name in the "Name" field and
a project storage location in the "Location" field.

4. Click the [OK] button.
The "Standard project" dialog box will be displayed.

5. Select "AGM1CSEC16T/P(Panasonic Corporation)" in the "Device" field and "Structured" in
the "Program in" field, and click the [OK] button.

10.2 Creating a New Project
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A new project will be created. Device and other objects including objects for ST programs
are arranged in the navigator pane.

<Uses of objects arranged in the navigator pane>

No. Name Function

(1) Device object Sets up device objects.

(2) Application object Sets up application objects.

(3) Program object (POU object) Sets up program objects (POU objects).

(4) Task object Sets up task objects.

● A new project can also be created from the menu bar by selecting File>New Project.

10.2 Creating a New Project
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10.3 Communication Setting

10.3.1 Setting the LAN Port

Configure communication settings for the LAN port using "Network setting" in the "PLC
Parameters” tab.
When connecting GM Programmer and the GM1 Controller via the LAN port, match the network
settings of the PC with those of the GM1 Controller.

1. Double-click the "Device(AGM1CSEC16T/P)" object in the navigator pane.
The device editor will open.

2. Open the "PLC Parameters" tab.

3. Check the network settings of the GM1 Controller and match the network settings of the PC
with those of the GM1 Controller.

4. Open the "Communication Settings" tab and click "Network scan".

5. Select a GM1 Controller to which you want to connect and click the [OK] button.

● If the network settings of the GM1 Controller have been changed, the changes will take
effect after the project is downloaded.

10.3.2 Adding USB Ports

This function allows the user to set a USB port as the communication interface between a tool
such as GM Programmer or PANATERM Lite for GM and the GM1 Controller.

1. Connect the GM1 Controller and PC with a USB cable.

2. From the menu bar, select Online>Add USB Port.

10.3 Communication Setting
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The "Add USB Port" dialog box will be displayed.

3. Click the [OK] button.
A dialog box to restart the Gateway will be displayed.

4. Click the [OK] button.
The "Select Device" dialog box will be displayed.

10.3 Communication Setting
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5. Select a GM1 Controller to which you want to connect and click the [OK] button.
When the connection is completed, a dialog box will be displayed to notify successful
connection.

6. Click the [OK] button.
A USB port will be added as the communication interface between the PC and GM1
Controller.

10.3 Communication Setting
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10.4 Basic Setting for GM1 Controller

Set a control cycle for the GM1 Controller.

1. Double-click the MotionTask object in the navigator pane.

The "MotionTask" editor will open in the main pane.

2. Set a control cycle.

10.4 Basic Setting for GM1 Controller
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10.5 Adding and Setting up Servo Amplifiers

This section explains how to add device objects for servo amplifiers to a project and set them
up.
The description below explains how to add device objects for A5B servo amplifiers to a project
and how to set them up.

1. Right-click the EtherCAT_Master_SoftMotion object in the navigator pane and then select
Add Device from the context-sensitive menu that is displayed.

The "Add Device" dialog box will be displayed.

2. Select a device object for the servo amplifier.

10.5 Adding and Setting up Servo Amplifiers

10-10 WUME-GM1ETCSU-04



The selected device object of the servo amplifier will be added.

3. Click the [Add Device] button.
The selected device object of the servo amplifier will be added to the navigator pane.

Click the [Cancel] button to close the "Select Device” dialog box.

4. Double-click the added object.
The setting pane will be displayed in the main pane.

10.5 Adding and Setting up Servo Amplifiers
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● To remove a device object that has been added, select the device object in the navigator
pane and press the <Delete> key.

5. Select the "Enable expert settings" check box.

6. Set a station alias.
How to set a station alias differs according to the setting of Pr7.41 in "8.1.3 Initial Setup for
Servo Amplifiers".

● When Pr.7.41 is set to 0

10.5 Adding and Setting up Servo Amplifiers
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Select the "Configured station alias” option and enter the setting of the rotary switch on the
front panel of the servo amplifier and the setting of Pr7.40 into the input field.
　Example: When the value of the rotary switch on the front panel of the servo amplifier is
set to 8 and the value of Pr7.40 is set to 1
The high-order 8 bits and low-order 8 bits represent 1 and 8, respectively. Therefore, enter
264 in the input field.

Station alias

High-order 8 bits Low-order 8 bits

3740H setting Rotary switch setting

● When Pr.7.41 is set to 1
Select the "Disable” option.
The numerical value displayed in "EtherCAT address” is set as the station alias value.

10.5 Adding and Setting up Servo Amplifiers
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● You can also set any desired value after logging in by selecting the configured station alias
value.
Enter any desired value in the input field and click the [Write to Eeprom] button.

When you log in again after restarting the servo amplifier, the value entered in the input field
is set as the station alias value.
If you log in for the first time after selecting the "Configured station alias” option, station alias
value inconsistency will occur, causing the device name of the servo amplifier in the
navigator pane to be grayed out.

10.5 Adding and Setting up Servo Amplifiers
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10.6 Basic Settings for EtherCAT Axes

● Be sure to configure settings for EtherCAT axes.

1. Double-click the servo amplifier object in the navigator pane.

The setting pane will be displayed in the main pane.

10.6.1 General Settings

Select the "General" tab and set the following items.

10.6 Basic Settings for EtherCAT Axes
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(1) Virtual mode
You can set real axes or virtual axes.
Use of real axes: Real axes are used to actually control the servo amplifier.
Use of virtual axes: Virtual axes create and execute a virtual servo amplifier within the GM1
Controller.

(2) Modulo / Finite
The axis type can be specified.
● Modulo

Modulo: The motor rotates infinitely (belt drive, etc.) without limiting the travel range.
• The value of the commanded position keeps looping between 0 and modulo value.
• The maximum settable modulo value is "255×units in application" (*1).

*1: For "units in application", specify settings in the "Scaling / Mapping" tab.
• A negative value cannot be set. (A warning is issued. If a download is performed without

correcting the value, an error will occur when the GM1 Controller is started.

● Finite
The set value of the commanded position is a finite value.
Soft limits can be set. Note that an error will occur if a 32-bit real number is exceeded.

(3) Soft limits
If the axis type is set to "Finite", soft limits can be set.
If the commanded position falls outside the soft limit setting range, an error stop will occur,
causing the operation to stop.
If the operation is stopped because the soft limit setting range is exceeded, the value specified
in "Deceleration” or “Max. distance" in "Soft error reaction" or the value specified in
"Deceleration” in "Dynamic limits" will be applied, whichever is the shortest time from when
deceleration starts until a stoppage occurs.

(4) Software error reaction
Settings can be configured to stop operation when an error occurs.

10.6 Basic Settings for EtherCAT Axes
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● If the mode is switched from run to stop during operation, an emergency stop will be executed,
regardless of the settings in "Software error reaction".

● For stop operation that takes place when an error stop occurs or when the soft limit range is
exceeded, one of the values specified in the following items is applied, whichever is the
shortest time from when deceleration starts until a stoppage occurs.
• "Deceleration" in "Software error reaction"
• "Max. distance" in "Software error reaction"
• "Deceleration" in "Dynamic limits"

● If "Deceleration" and "Max. distance" in "Software error reaction" are set to 0, these settings will
be disabled. In this case, operation is stopped according to the value specified in
"Deceleration" in "Dynamic limits".

(5) Dynamic limits
"Velocity", "Acceleration", and "Deceleration" cannot be set to 0. If they are set to 0, a warning
will be issued.

The "SMC_CheckLimits" function block can be used to check whether the values set in
"Dynamic limits" were exceeded during axis operations. Note that the "SMC_CheckLimits"
function block cannot detect whether the value set in "Jerk” was exceeded. Therefore, do not
use the "Jerk" field.

10.6.2 Scaling / Mapping Settings

Select the "Scaling / Mapping" tab and set the following items.

10.6 Basic Settings for EtherCAT Axes
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(6) Scaling / Mapping
● Rotary type

When the axis type is set to "Modulo", the ratio in conversion from drive increments to the
application unit is set.
The unit on the servo amplifier and the unit on the application (POU) are converted.
Example:
One revolution of the MINAS A6B MADHT1105BA1 is 0x800000. To treat one revolution as
360 in the application, set this ratio to 360.

Invert direction: The direction is reversed.
● Linear type

When the axis type is set to "Finite", the ratio in conversion from drive increments to the
application unit is set.

10.6 Basic Settings for EtherCAT Axes
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Invert direction: The direction is reversed.

10.6 Basic Settings for EtherCAT Axes
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10.7 Connecting to the GM1 Controller

Connect the PC where the GM Programmer is installed to the GM1 Controller.
The connection status of the PC includes "Connected", "Connection as a device user", "Login",
and "Online config mode".
Depending on the connection status, operations that can be executed are different.
If the Controller is provided with a device user registration, connection must be made as the
device user.

■ Without device user registration

List of available GM1 Controller operations

Function Not connected Connected Login Online config mode

Setting / acquiring Controller
information

× ○ ○(Note 1) ×

Application management × ×(Note 2) ○ ×

Reset × ×(Note 3) ○ ×(Note 4)

Security × × ○ ○

Debug × × ○ ×

Commissioning × × × ○
 

(Note 1) Not possible to operate the PLC Shell.
(Note 2) Possible to upload the source.
(Note 3) Possible to reset the device (PLC initialization) or to delete device application from the device.
(Note 4) Possible to reset the device (PLC initialization).
 

10.7 Connecting to the GM1 Controller
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■ With device user registration

List of available GM1 Controller operations

Function Not
connected

Connected \as a device user Login Online config
mode

Setting / acquiring
Controller information

× × ○ ○(Note 1) ×

Application management × × ×(Note 2) ○ ×

Reset × × ×(Note 3) ○ ×(Note 4)

Security × × ○(Note 5) ○ ○

Debug × × × ○ ×

Commissioning × × × × ○
 

(Note 1) Not possible to operate the PLC Shell.
(Note 2) Possible to upload the source.
(Note 3) Possible to reset the device (PLC initialization) or to delete device application from the device.
(Note 4) Possible to reset the device (PLC initialization).
(Note 5) Addition of the device user, changing the password for the device user, or deletion of the device user

cannot be made if the user of the Device Editor is not synchronized with "Synchronization" of the
group tab.

 

10.7 Connecting to the GM1 Controller
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10.8 Commissioning

10.8.1 Online Config Mode

When the online config mode is selected, the servo amplifiers are set to be connected to the
GM1 Controller.

When using the online config mode, perform the setting as described in "10.3 Communication
Setting" in advance.

1. From the menu bar, select Project>Online Config Mode.
A confirmation message will be displayed, asking whether to remove all applications.

2. Click [Yes].
All applications will be removed from the GM1 controller, and the GM1 controller and servo
amplifiers will be connected in online config mode.
While online config mode is in progress, "Online Config Mode" in the menu bar remains
selected.

● To cancel the online config mode, select Project>Online Config Mode from the menu bar
again.

10.8 Commissioning
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10.8.2 Conducting Commissioning for Servo Amplifiers

While in online config mode, you can conduct commissioning for servo amplifiers.
There is no need to create a program for commissioning.
The following is an example of commissioning using the A5B-series servo amplifiers.

1. Double-click the servo amplifier object in the navigator pane.

The "EtherCAT Axis Setting" dialog box will be displayed.

2. Click the "Commissioning" tab.
The Commissioning pane will be displayed.

No. Group Description

(1) Status Displays the running status of the servo amplifiers during
commissioning.

(2) Error
Displays errors that occurred during commissioning.
Allows the user to clear errors.

10.8 Commissioning
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No. Group Description

(3) Operation
Allows the user to set commissioning parameters.
Allows the user to execute commissioning.

3. Click an appropriate button in the Operation group to start commissioning.
Clicking an icon starts the corresponding commissioning.
To change home return parameters, use the "Program" tab.

4. For the servo amplifier status during commissioning, check the "Status" and "Error" groups.

4-1 To clear errors that are displayed, click the [Reset] button in the "Operation" group.
Clicking the [Reset] button clears all errors.

5. From the menu bar, select Project>Online Config Mode.
Online config mode will be canceled and commissioning will be terminated.

This completes commissioning for servo amplifiers.

● Even if communication with the servo amplifier is disrupted during "Inching" or "Home Return"
operation, the servo amplifier will continue commissioning operation.

● If online config mode is canceled, commissioning will be terminated. To cancel the online config
mode, select Project>Online Config Mode from the menu bar again.

10.8 Commissioning
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10.9 Login

GM Programmer allows the user to log in to the GM1 Controller. When "Login" is executed,
applications are downloaded to the GM1 Controller.

1. From the menu bar, select Online>Login, or press the <Alt> key and the <F8> key
simultaneously.
A confirmation message will be displayed, asking whether to download the applications to
the GM1 controller (device).

2. Click [Yes].
The applications will be downloaded to the GM1 Controller at the same time as you log in to
the GM1 Controller (device).
"connected" will be displayed at the [Device] object in the navigator pane and the status of
the downloaded applications will be displayed.

● You can also log in by clicking  on the toolbar.
● If you log in again after the applications have been downloaded, the confirmation message will

not be displayed.

10.9 Login
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10.10 Logout

This function allows the user to log out from the device to which the user logged in.

1. From the menu bar, select Online>Logout, or press the <Ctrl > + <F8> key simultaneously.
You will be logged out.

● You can also log out by clicking  on the toolbar.

10.10 Logout
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11.1 Setting up the Servo Amplifier Connected to the GM1 Controller

This section explains how to set up MINAS series servo amplifiers connected to the GM1
Controller.
For other devices, refer to their instruction manuals when setting up them.
The PC communicates with the servo amplifier connected to the GM1 Controller.
Connect the PC and GM1 Controller with an Ethernet cable or USB cable. With the GM1
Controller and servo amplifier connected with a Cat5e shielded cable, set up the servo
amplifier.

● Perform this setup work only after the connection between the GM1 Controller and the
servo amplifier has been established.

11.1.1 If Connected with Ethernet Cables

If connected with Ethernet cables, use the following procedure.

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

2. Select "Connect to the GM series controller with LAN" and click the [OK] button.
The "Communication timeout settings" dialog box will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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3. Change the timeout period and click the [OK] button.
The "Select Device" dialog box will be displayed.

4. Click the [Search Network] button, select the GM1 Controller, and click the [OK] button.
The main pane will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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11.1.2 If Connected with USB Cables

If connected with USB cables, use the following procedure.

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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2. Select "Connect to the GM series controller with USB" and click the [OK] button.
The "Add USB Port" dialog box will be displayed.

3. Change the timeout period and click the [OK] button.
A message window will be displayed, asking whether to add a USB port and restart the
Gateway.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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4. Click the [OK] button.
The "Select Device" dialog box will be displayed.

5. Click the [Search Network] button, select the GM1 Controller, and click the [OK] button.
The main pane will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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11.2 Writing Parameters to Servo Amplifier

By connecting the PC and a servo amplifier, the parameters set with PANATERM Lite for GM
can be written directly to the servo amplifier.

1. Start PANATERM Lite for GM.

2. Click "Trans" on the toolbar.
The parameters will be sent from PANATERM Lite for GM to the servo amplifier.

● If you have changed parameters on a yellow background, click "EEP" on the toolbar to restart
the servo amplifier.

11.2 Writing Parameters to Servo Amplifier
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11.3 Writing Objects to Servo Amplifier

By connecting the PC and a servo amplifier, the objects set with PANATERM Lite for GM can
be written directly to the servo amplifier.

1. Start PANATERM Lite for GM.

2. Click [Trans] on the toolbar.
The objects will be sent from PANATERM Lite for GM to the servo amplifier.

3. Click the [EEP] button to write the objects to the EEPROM of the servo amplifier.

11.3 Writing Objects to Servo Amplifier
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12.1 Checking Wiring

Firstly, check whether the GM1 Controller, expansion units, servo amplifier, and PC are
connected correctly.

12.1 Checking Wiring

12-2 WUME-GM1ETCSU-04



12.2 Checking Safety Circuit Design

12.2.1 Safety Circuit Design

■ Example of a safety circuit
Be sure to create a safety circuit when using this product.

Installation of over limit switches

● Install over limit switches as shown above.
● Connect them to the CW and CCW over-travel inhibit inputs of the parallel I/O connector of

the servo amplifier. The GM1 Controller receives these inputs as limit (+) and limit (-) inputs
through the network.

● Install the safety circuit recommended by the manufacturer of the motor being used.

12.2 Checking Safety Circuit Design
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12.2.2 Items to Check during Wiring

■ System configuration example

(1) Checking connections of each device
Check whether each device has been connected as indicated by the design.

(2) Checking the installation of an external safety circuit
Check that the safety circuit is installed as an external circuit by installing and wiring over limit
switches properly.

(3) Checking the settings for power ON sequence
Check whether settings have been configured so that the power is turned on in sequence.

(4) Checking the GM1 Controller mode selector switch
Set the GM1 Controller to STOP mode. Setting to RUN mode can cause unexpected
operation.

12.2.3 Power ON Operation

When turning ON the power to the system incorporating the GM1 Controller, follow the power
ON sequence described in the procedure below.

● Consider the performance and statuses of any external devices connected to the system,
and take sufficient care so that turning ON the power will not initiate unexpected
movements.

12.2 Checking Safety Circuit Design
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1. Turn ON the power to the I/O devices connected to the GM1 Controller.

2. Turn ON the power to the servo amplifier.

3. Turn ON the power to the GM1 Controller.

12.2.4 Power OFF Operation

1. Check that the rotation of the motor has stopped and then turn OFF the power to the GM1
Controller.

2. Turn OFF the power to the servo amplifier.

3. Turn OFF the power to the I/O devices connected to the GM1 Controller.

12.2 Checking Safety Circuit Design
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12.3 Operation Check

12.3.1 Checking the Network

After turning ON the power supplies, check if the operation monitor LEDs of the GM1 Controller
are in the following states.
● STATUS: Lit
● LINK: Lit

● If the "STATUS" LED is flashing, the network is not established.
● If the "LINK" LED is not lit, the “RX” (reception side) of the GM1 Controller and “TX”

(transmission side) of the servo amplifier are not electrically connected normally.

12.3.2 Checking Input Signals

Check the inputs of the over limit switches for the safety circuit that are connected to the servo
amplifier and the input of the near home (DOG) switch.
By operating each switch forcibly, check whether signals are normally input into the GM1
Controller.
The input state of each switch can be checked on the monitor screen of the MINAS setup
support software "PANATERM Lite for GM".

● After the over limit switches are installed, if the moving direction of the motor is reverse to the
limit (+) and limit (-) positions, review the physical connections of each limit switch.

12.3 Operation Check
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12.3.3 Checking the Rotation and Movement Directions and Movement
Distance

Check whether the rotation and movement directions of the motor and the movement distance
are correct. Movements can be easily checked using the commissioning function of GM
Programmer without having to create a user program.

■ Using the commissioning function
In GM Programmer, select Project>Online Config Mode.
Opening the commissioning window for each axis allows you to use the commissioning
function.

■ Checking the rotation direction
Set the rotation direction on the servo amplifier.
Check the rotation direction by executing inching operation in the commissioning window.

12.3 Operation Check
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■ Checking the movement distance
Set the movement distance on the servo amplifier.
Then, set the scale in the "Scaling / Mapping" window for each axis in GM Programmer.
Check the movement distance by executing inching operation in the commissioning window.

For details on inching operation in the commissioning window, refer to "10.8.2 Conducting
Commissioning for Servo Amplifiers".

12.3 Operation Check
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Warranty

Warranty Period

The warranty period of the Product shall be 12 months from the ex-factory date or 18 months
from the date of manufacturing unless otherwise specified between both parties.

Warranty Scope

Panasonic warrants the replacement of the defected parts of the Product or repair of them
when the defects of the Product occur during the Warranty Period, and when the defects are
under Panasonic responsibility. This Warranty only covers the Product itself and does not cover
any damage to your company and the third party incurred by the Product, such as damage that
is induced by an object machined or produced using the Product or by the defects of the
Product. This Warranty shall be exempted in the following cases,
1. Defects resulting from misuse and/or repair or modification by the customer.
2. Defects resulting from drop of the Product or damage during transportation.
3. Defects resulting from improper usage of the Product beyond the Specifications.
4. Defects resulting from fire, earthquake, lightening, flood, damage from salt, abnormal

voltage or other Act of God, or other disaster.
5. Defects resulting from the intrusion of foreign material to the Product, such as water, oil or

metallic particles.
6. Parts exceeding their standard lifetime specified in this document.
7. The machines are not assembled in accordance with the instructions or precautions noted

in this specification.
8. When the machine does not match the Product assembled in the machine.
9. When the machine condition is not caused by Panasonic reasons.
10. Defects that Panasonic could not foresee at the time of delivery of the Prodcuct.

Warranty
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Cautions for Proper Use

■ Selection of a power supply
● Use a low noise power supply.
● The inherent noise resistance is sufficient for the noise superimposed on the power wires,

however, the noise can be attenuated further by using the isolation transformer / insulated
power supply.

■ Isolation of power supply systems
● Wiring to the units, I/O devices, and other power devices should have separate wiring

systems.

■ Power supply sequence
● Start the GM1 controller only after I/O devices and power devices are energized.

In case of stopping the operation of the GM1 controller, have the I/O devices or power
devices turned OFF after the GM1 controller has stopped operating.

■ Grounding
● The grounding connection should have a resistance of 100 Ω or less.
● The point of grounding should be as close to the GM1 controller as possible. The ground

wire should be as short as possible.
● Sharing the ground with another device may have an adverse effect. Therefore, be sure that

grounding is dedicated.

Conversely, depending on your environment, grounding may cause a problem. Do not ground
the function earth when grounding a plus (+) terminal of the power.

Cautions for Proper Use
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■ Wiring
● Turn OFF the power supply when carry out wiring or connecting the GM1 controller to

expansion units.
● Noise resistance measures such as attaching a noise filter, a surge absorber or a ferrite core

may be necessary in some cases, depending on the usage environment.

■ Installation of an interlock circuit
● When controlling conflicting operations such as the motor rotation in clockwise or counter-

clockwise direction, provide an interlock circuit external to the GM1 controller.

■ Installation of an emergency stop circuit
● Provide an emergency stop circuit external to the GM1 controller to turn OFF the power

supply of the output device.

■ Installation environment
Do not use it in the following environments.
● Direct sunlight
● Sudden temperature changes causing condensation.
● Inflammable or corrosive gas.
● Excessive airborne dust, metal particles or saline matter.
● Benzine, paint thinner, alcohol or other organic solvents or strong alkaline solutions such as

ammonia or caustic soda.
● Direct vibration, shock or direct drop of water.
● Influence from power transmission lines, high voltage equipment, power cables, power

equipment, radio transmitters, or any other equipment that would generate high switching
surges. (100 mm or more)

■ Handling instructions
● Before touching the unit, always touch a grounded piece of metal in order to discharge static

electricity.
● Always rid yourself of any static electricity before handling this product.
● Do not connect a unit other than our GM1 series to the side connector on the unit.
● Use copper wires with a temperature rating of 90°C or higher.

Cautions for Proper Use
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